The Diesel Truck Site  

Go Back   The Diesel Truck Site > Diesel Truck Forums > Dodge Cummins Forum

Dodge Cummins Forum Dodge Cummins Forum


Reply
 
Thread Tools Display Modes
  #41  
Old 08-05-2011, 09:10 PM
NikkiMn's Avatar
NikkiMn NikkiMn is offline
Trouble Maker
 
Join Date: Nov 2010
Location: Northern Mn
Posts: 92
Default

Well after not doing anything to my truck since the last time we cleaned the servo I randomly decided to try out the cruise since I was driving to Minneapolis to help my bro... And it worked... This was about a week ago and it has worked ever since... Figure that one out lol.
__________________
1998 Dodge Ram 2500 12v Quad Cab with a Georends tranny... a little less then stock
Reply With Quote
  #42  
Old 05-03-2012, 08:42 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

Quote:
Originally Posted by NikkiMn View Post
Well after not doing anything to my truck since the last time we cleaned the servo I randomly decided to try out the cruise since I was driving to Minneapolis to help my bro... And it worked... This was about a week ago and it has worked ever since... Figure that one out lol.
I know this is an old thread, but the servo went wacky shortly after her last post. We did fix the cruise finally (it seems). I found a a servo on E-Bay for $45. It got here and when we went to put it on the plug was different, but that was an easy fix. I heated up the solder connections with a soldering gun and with a puff of 120 psi of air the melted solder disappeared! Then I was able to lift the connector right off and put the other one on for her truck. Plugged it in and hooked it up and it didn't work....at all. It was a few days before I saw the truck again and I told her to pop the hood. Sure enough, between the two of us working on it the cable never got hooked up to the throttle....... We hooked it up and she said it now works better than it ever has!! Anyhow, I have some pictures and will try to get them on here tomorrow.
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #43  
Old 05-04-2012, 08:22 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

Here are the pictures as promised!
This is the solenoid pack with the incorrect connector:


Here is what the old original pack looks like with the needed connector not attached and next to it.



Here is the solder job of putting the connector on:


And here is the reassembly. No, that is not my hand...


The rest is just a matter of putting the truck back together again.
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #44  
Old 05-04-2012, 09:33 PM
ISX's Avatar
ISX ISX is offline
Senior Member
 
Join Date: Nov 2010
Posts: 268
Default

I can't remember but I think the 1994 trucks had that weird squared off one. All the 1994 trucks also have flawless cruise controls. Maybe theres some crappy electrical component inside all the newer ones thats finicky.
__________________
1997-12V-NV4500-Dana 80/3.54/2wd-350k---21-27mpg
Removed AFC--No Plate--13.5* timing--BHAF--5" Exhaust--Valair Clutch
1994-Jeep Cherokee-5spd-3.07-4wd-202k---16-19mpg
Reply With Quote
  #45  
Old 05-04-2012, 09:40 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

Quote:
Originally Posted by ISX View Post
I can't remember but I think the 1994 trucks had that weird squared off one. All the 1994 trucks also have flawless cruise controls. Maybe theres some crappy electrical component inside all the newer ones thats finicky.
Could be, but as you can see there is no electronics on what I worked on. Just connections to the solenoids. What the pictures show is that you can retro fit any of them to your truck.
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #46  
Old 05-05-2012, 06:18 AM
ISX's Avatar
ISX ISX is offline
Senior Member
 
Join Date: Nov 2010
Posts: 268
Default

I wonder if there is any difference in the coils that do all the actuating.
__________________
1997-12V-NV4500-Dana 80/3.54/2wd-350k---21-27mpg
Removed AFC--No Plate--13.5* timing--BHAF--5" Exhaust--Valair Clutch
1994-Jeep Cherokee-5spd-3.07-4wd-202k---16-19mpg
Reply With Quote
  #47  
Old 05-05-2012, 06:36 AM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

Quote:
Originally Posted by ISX View Post
I wonder if there is any difference in the coils that do all the actuating.
It sure didn't look like there was any difference. I also checked the coils with 12 volts and they worked perfectly. Do you suppose the coils operate at a lower voltage?
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #48  
Old 05-05-2012, 08:53 AM
ISX's Avatar
ISX ISX is offline
Senior Member
 
Join Date: Nov 2010
Posts: 268
Default

I have no idea. But that one is a 1994, a guy around here has a 1994 with perfect cruise as well. How do these older trucks still have working cruises when my 1997 crapped out long ago.. Something has to be different and if they went to the trouble of changing from the square contacts to the flat ones then I would imagine that isn't the only thing that changed.
__________________
1997-12V-NV4500-Dana 80/3.54/2wd-350k---21-27mpg
Removed AFC--No Plate--13.5* timing--BHAF--5" Exhaust--Valair Clutch
1994-Jeep Cherokee-5spd-3.07-4wd-202k---16-19mpg
Reply With Quote
  #49  
Old 05-05-2012, 09:14 AM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

I know what you mean. My '96 has never had a cruise issue, and the body on mine and also on a '94 Ram in the area are in way better shape than all the newer ones including Nikki's '98!
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #50  
Old 05-05-2012, 10:43 AM
ISX's Avatar
ISX ISX is offline
Senior Member
 
Join Date: Nov 2010
Posts: 268
Default

They added something to the paint in 97 and maybe 98 that completely screws them over. My silver paint has green spots where the clear coat peals off and now the paints just falling off. The roof looks like someone took a brillo pad to it and that just happened in the last year.
__________________
1997-12V-NV4500-Dana 80/3.54/2wd-350k---21-27mpg
Removed AFC--No Plate--13.5* timing--BHAF--5" Exhaust--Valair Clutch
1994-Jeep Cherokee-5spd-3.07-4wd-202k---16-19mpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:57 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Skin & Style Created By: Mopar1973Man.Com
Copyright 2012 Diesel Truck Site