The Diesel Truck Site  

Go Back   The Diesel Truck Site > Diesel Truck Forums > Chevrolet & GMC Duramax Forum

Chevrolet & GMC Duramax Forum Chevrolet & GMC Duramax Forum


Reply
 
Thread Tools Display Modes
  #11  
Old 03-19-2015, 07:51 PM
chuck chuck is offline
Junior Member
 
Join Date: Mar 2015
Posts: 9
Default

I found other wire is for a different type of AC. I did run a scanner the other day I imagine iam in for a world of trouble. P0101,P0236,p0272,po278,p1216,p1218,p1641. I assume I need a new ip or head.


Sent from my iPhone using Tapatalk
Reply With Quote
  #12  
Old 03-19-2015, 08:23 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,912
Default

P0101 is a MAF (Mass Air Flow) problem. http://www.obd-codes.com/p0101
P0236 is Turbocharger Boost Sensor A Circuit Range/Performance
very common indicator of a failing wastegate solenoid (or cracked vac line)
P0272 is described as a cylinder number 4 contribution/balance. In essence, this code is stating that the number four cylinder in the firing order is experiencing a fuel-related problem.
P0272 is Cylinder #4 Contribution/balance. What that generally means is cylinder #4 has a fuel related problem.
P0278 is Cylinder #6 Contribution/balance. The same as P0272.
P1216 is an Injection Pump code, but before you condemn the pump try another FSD (fuel solenoid (fuel solenoid driver)
P1218 is The pcm uses a calibrated resister
internally in the injection pump(PMC resistor) to determine
fuel rates. the resister value is stored in the pcm memory.
If the pcm memory has been disturbed or replaced the pcm will relearn the resister value on the next ign cycle. The calibration resistor is located in the PMD/FSD connector socket. If you've disconnected the harness, it may have fallen out. In my experience, you can't easily get the dang thing out when you need to, but if you turn your back on it, it will fall out.
P1641 -- Malfunction Indicator Lamp (MIL) Control Circuit. Not sure what to tell you about that one.
Judging by the codes it sounds a lot like your Fuel Solenoid Driver (electronics on the IP) are giving fits. It could be the electronics going goofy or it could be a poor connection at the pump/wiring harness or even a bad ground. The suggestions about replacing the FSD have all said to get the relocation harness and get it away from the heat of the engine.
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #13  
Old 03-19-2015, 08:26 PM
stodg73's Avatar
stodg73 stodg73 is offline
Out There, Savin' Lives
 
Join Date: Nov 2010
Location: Southern Colorado
Posts: 2,321
Default

P0101 - Mass air flow or volume air flow circuit, range or performance problem
P0236 - Turbocharger boost sensor 'a' circuit malfunction
P0272 - Cylinder no. 4 contribution/balance fault
P0278 - Cylinder no. 6 contribution/balance fault
P1216 - Fuel solenoid response time too short
P1218 - Injection pump calibration
P1641 - Malfunction Indicator Lamp (MIL) control circuit

Clear the codes and see what comes back.


Tom beat me to it...
__________________
O.O., 01.5, Dodge, 2500, High Output (H.O.) Cummins Turbo Diesel (245/505), Quad Cab Long Bed (QCLB), 4x4, Sport, Original Bosch VP 44 Injection Pump, 6 Speed/NV5600 Transmission, 3.55 Gears, 105k, currently stock engine, Fram Air Filter, 285/75R16s, Glow Shift Gauges: Fuel Pressure (FP), Boost, Exhaust Gas Temperature (EGT), Oil Temperature, SMARTY@1, Airtex lift pump 19 psi @ idle, 14 psi @ WOT, Propane Injection, 2 Stroke Oil, Intake Air Temperature (IAT) Fooler = Better MPG, Bed Lined, Chrome Nerf Bars, more to come!!

Toys:
'79 CJ5, 258ci, 3" lift, 33x12.50x15, Stock Engine and 3 Speed Tranny
'05 Suzuki, GSX1300R, Hayabusa, All Stock, #3('00 blown engine, '00 stolen, & '05)
The complete live & learn and pass it on by H. Jackson Brown, Jr.
Reply With Quote
  #14  
Old 03-19-2015, 08:28 PM
stodg73's Avatar
stodg73 stodg73 is offline
Out There, Savin' Lives
 
Join Date: Nov 2010
Location: Southern Colorado
Posts: 2,321
Default

Make sure that the grounds are good and clean as well.
__________________
O.O., 01.5, Dodge, 2500, High Output (H.O.) Cummins Turbo Diesel (245/505), Quad Cab Long Bed (QCLB), 4x4, Sport, Original Bosch VP 44 Injection Pump, 6 Speed/NV5600 Transmission, 3.55 Gears, 105k, currently stock engine, Fram Air Filter, 285/75R16s, Glow Shift Gauges: Fuel Pressure (FP), Boost, Exhaust Gas Temperature (EGT), Oil Temperature, SMARTY@1, Airtex lift pump 19 psi @ idle, 14 psi @ WOT, Propane Injection, 2 Stroke Oil, Intake Air Temperature (IAT) Fooler = Better MPG, Bed Lined, Chrome Nerf Bars, more to come!!

Toys:
'79 CJ5, 258ci, 3" lift, 33x12.50x15, Stock Engine and 3 Speed Tranny
'05 Suzuki, GSX1300R, Hayabusa, All Stock, #3('00 blown engine, '00 stolen, & '05)
The complete live & learn and pass it on by H. Jackson Brown, Jr.
Reply With Quote
  #15  
Old 03-20-2015, 10:49 AM
chuck chuck is offline
Junior Member
 
Join Date: Mar 2015
Posts: 9
Default

Ok thank you guys. I did a relocate on the pmd. Before I swapped engines I did the valve cover so I might of got dirt in the injectors. I have spare egr and maf sensor. Yesterday my waste gate was fine today it seems to have a leek


Sent from my iPhone using Tapatalk
Reply With Quote
  #16  
Old 03-20-2015, 10:56 AM
chuck chuck is offline
Junior Member
 
Join Date: Mar 2015
Posts: 9
Default

Resistor did fall out


Sent from my iPhone using Tapatalk
Reply With Quote
  #17  
Old 03-20-2015, 11:56 AM
chuck chuck is offline
Junior Member
 
Join Date: Mar 2015
Posts: 9
Default

So I put the resistor in and it's running much better. It died and wouldn't start I started playing with the wires I think it might just be grounds and pos cables. I put a new terminal on and it started up and ran a lot better


Sent from my iPhone using Tapatalk
Reply With Quote
  #18  
Old 03-20-2015, 07:17 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,912
Default

AAHHHhhhhh!! You are making progress! Glad to hear that!! Keep up the good work!
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:47 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Skin & Style Created By: Mopar1973Man.Com
Copyright 2012 Diesel Truck Site