The Diesel Truck Site  

Go Back   The Diesel Truck Site > Diesel Truck Forums > Dodge Cummins Forum

Dodge Cummins Forum Dodge Cummins Forum


Reply
 
Thread Tools Display Modes
  #31  
Old 12-29-2013, 08:39 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

P0541 Dodge - Intake Air Heater Relay 1 Low

Possible causes
- Faulty Intake Air Heater Relay
- Intake Air Heater Relay harness is open or shorted
- Intake Air Heater Relay circuit poor electrical connection

P2607 - Intake Air Heater 'B' Circuit Low

Possible causes

Same as above




P0237 - Turbocharger/Supercharger Boost Sensor 'A' Circuit Low

Possible causes
- Boost pressure sensor harness is open or shorted
- Boost pressure sensor circuit poor electrical connection
- Faulty boost pressure sensor
- Faulty Turbo/Super Charger
- Engine over temperature
- Ignition misfire exceeds the calibrated threshold
- Faulty Knock sensor (KS)

The last one does not have anything to do with it not starting. The first two could indicate a grid heater problem, but it sounds a bit like there is a voltage issue that you need to find. 200 RPM is about right for the starter. Since everything seems to be about where it should be it could very well be injectors. The ECM does not fire the injectors until the rail pressure reaches the set point (usually about 5000PSI). A cracked injector would cause the problem you have. See THIS PAGE for more info.
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #32  
Old 12-30-2013, 10:53 AM
winger99 winger99 is offline
Harley
 
Join Date: Oct 2013
Location: Sun City, AZ
Posts: 9
Default

Good morning MtTom: This morning it is 40 deg. here, I plugged in my truck last night, went out this AM and it did not turn over for 2 seconds until it had fired off. I just don't understand how that can happen if the injectors are leaking down the fuel pressure in the rail. If I don't plug it in it will crank until the batteries go dead! Any more thoughts until I can get home where I have the tools to work on it. My wife says just keep plugging it in and to he%% with fixing it, I don't think that is an option.
Reply With Quote
  #33  
Old 12-30-2013, 11:33 AM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

Now you really have me stumped. I didn't realize it would not start at all without being plugged in. Time for me to contact those smarter than me.....
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #34  
Old 12-30-2013, 11:55 AM
winger99 winger99 is offline
Harley
 
Join Date: Oct 2013
Location: Sun City, AZ
Posts: 9
Default

MtTom: I forgot to tell you that the P0237 may have set when my intercooler came apart! I now have a Aluminum welded intercooler no plastic endcaps!
Reply With Quote
  #35  
Old 12-30-2013, 02:22 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

Quote:
Originally Posted by winger99 View Post
MtTom: I forgot to tell you that the P0237 may have set when my intercooler came apart! I now have a Aluminum welded intercooler no plastic endcaps!
Well, that explains the low boost code. I keep coming back to the grid heater codes. Do they even heat up any?
Here is a message from a good mechanic I know:
Quote:
Two things. First and most common is a high fuel return rate usually causes by one or more bad injectors. Second is a preheat issue. Just cause the wait to start light comes on doesn't mean much
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #36  
Old 12-30-2013, 02:44 PM
winger99 winger99 is offline
Harley
 
Join Date: Oct 2013
Location: Sun City, AZ
Posts: 9
Default

They will heat up if I use the jumper switch that I put in, but that still will not let it start. Using the switch I put in I can see the voltage meter drop, and go to the engine and feel the heater grid block getting hot!
Reply With Quote
  #37  
Old 12-30-2013, 02:47 PM
stodg73's Avatar
stodg73 stodg73 is offline
Out There, Savin' Lives
 
Join Date: Nov 2010
Location: Southern Colorado
Posts: 2,328
Default

Winger, are you using a code reader or the key trick to get the codes?
__________________
O.O., 01.5, Dodge, 2500, High Output (H.O.) Cummins Turbo Diesel (245/505), Quad Cab Long Bed (QCLB), 4x4, Sport, Original Bosch VP 44 Injection Pump, 6 Speed/NV5600 Transmission, 3.55 Gears, 105k, currently stock engine, Fram Air Filter, 285/75R16s, Glow Shift Gauges: Fuel Pressure (FP), Boost, Exhaust Gas Temperature (EGT), Oil Temperature, SMARTY@1, Airtex lift pump 19 psi @ idle, 14 psi @ WOT, Propane Injection, 2 Stroke Oil, Intake Air Temperature (IAT) Fooler = Better MPG, Bed Lined, Chrome Nerf Bars, more to come!!

Toys:
'79 CJ5, 258ci, 3" lift, 33x12.50x15, Stock Engine and 3 Speed Tranny
'05 Suzuki, GSX1300R, Hayabusa, All Stock, #3('00 blown engine, '00 stolen, & '05)
The complete live & learn and pass it on by H. Jackson Brown, Jr.
Reply With Quote
  #38  
Old 12-30-2013, 04:42 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

  1. No or low fuel supply to the high pressure pump (CP3)
  2. Monitor rail pressure and see if you have over 4000 PSI during cranking, if not one or more injectors can cause a hard start, see injector section for further diagnostics. No smoke from the tailpipe after about 10 seconds of cranking means no fuel is getting into the cylinders.
  3. Injector connector tube not seated in injector, bad tube or improper torque on nut.
  4. Leaking fuel pressure limit valve, should not leak at idle or during cranking.
  5. Verify high pressure pump output volume (see high pressure pump info). You can also cap off all the injectors and see how quickly the rail pressure climbs. It takes about 4000 PSI rail pressure in order to start.
  6. Shorted fan clutch, unplug fan and try starting again.
This was cut and pasted from http://oregonfuelinjection.com/index...ostic-info.htm I am suspecting that #2 would be the one to concentrate on.
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
  #39  
Old 12-30-2013, 06:29 PM
winger99 winger99 is offline
Harley
 
Join Date: Oct 2013
Location: Sun City, AZ
Posts: 9
Default

Stodge73 the codes listed above are from the key trick. Had it to a friends house who had a code setup for his laptop and got the same codes about 3 weeks ago.
Reply With Quote
  #40  
Old 12-30-2013, 07:55 PM
MnTom's Avatar
MnTom MnTom is offline
Administrator
 
Join Date: Nov 2010
Location: Near Duluth, Mn
Posts: 4,929
Default

When you scanned it with your friend's computer, did you erase the codes? Just wondering if they are old or recurring.
__________________
1996 RAM "Custom Ground" 100 plate 3/4 forward, 300 injectors, 16.5 timing, Goerends Auto = 365HP, 833TQ Third Gen Rims, Aluminum Headache Rack
Duct Tape can't fix stupid, BUT it can muffle the sound
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:56 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Skin & Style Created By: Mopar1973Man.Com
Copyright 2012 Diesel Truck Site